re = /^\d+:(?!K1663$).*$/m
str = '3:K1675
4:K1663
5:K1663
6:K1663
7:K1663
8:K1675
13:K1675
14:K1675'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end