package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(\d{2})(\d{2})\b`)
var str = `test 123456 1234 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}