$re = '/\b(\d{2})(\d{2})\b/';
$str = 'test 123456 1234 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);