package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)P0{5}(\d{4}):(.+)`)
var str = `P000004245:TESTING THIS NC STRING
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}