import re
regex = re.compile(r"(?<=.).(?=[^@]*?@)")
test_str = "john.doe@gmail.com"
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)