$re = '/:((?:.*\n?)+?)(?=.*:|$)/m';
$str = 'Name: Al\'s
Place
Country:
State
Province: RI
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);