re = /:((?:.*\n?)+?)(?=.*:|$)/m
str = 'Name: Al\'s
Place
Country:
State
Province: RI
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end