package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(\s*(\d+(\.\d+)?(?:\s*)р?)\s*\)`)
var str = `( 456 р )
( 122 )
( 122.12р )`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}