$re = '/\(\s*(\d+(\.\d+)?(?:\s*)р?)\s*\)/u';
$str = '( 456 р )
( 122 )
( 122.12р )';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);