package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)id="(\w+)"`)
var str = `span id="testing" This is testing span a id="test" link a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}