$re = '/id="(\w+)"/m';
$str = 'span id="testing" This is testing span a id="test" link a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);