package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[([0-9:]+)\] .* ([-+0-9]+) fpm, gear lever: ([a-z]+), pitch: ([0-9]+), roll: ([a-z]+), ([0-9]+) kts`)
var str = `[11:36:19] Touched down at -56 fpm, gear lever: down, pitch: 3, roll: level, 116 kts`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}