const regex = /\[([0-9:]+)\] .* ([-+0-9]+) fpm, gear lever: ([a-z]+), pitch: ([0-9]+), roll: ([a-z]+), ([0-9]+) kts/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([0-9:]+)\\] .* ([-+0-9]+) fpm, gear lever: ([a-z]+), pitch: ([0-9]+), roll: ([a-z]+), ([0-9]+) kts', 'g')
const str = `[11:36:19] Touched down at -56 fpm, gear lever: down, pitch: 3, roll: level, 116 kts`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}