# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([A-Z,0-9, ]*\d ){0,1}(?:(\d\d)(\d\d)\\/){0,1}([a-z,A-Z,0-9, ,\-,',_,\.,\\/ ,\*]*)(?<= )(?:(?:(\-|\+)(\d*,\d\d)){0,1}|(.*))
/Nom rationnalisé: $4 $7\rMoyen de paiement: $1\rDate opération :$2\/$3\r\r/g;t' <<< "CARTE X1796 1209/FREE MOBILE 75 PARIS
CARTE 51002 ITUNES.COM/BILL LUXEMBURG
CARTE X1796 0209/SNCF INTERNET 75 PARIS CEDEX 09
CARTE X1796 1408/THE COLUMBIA STO 124 -156,76
CARTE X1796 1208/NICKLAUS NORTH G 124 -168,41
CARTE 51002 PAYPAL*DIGITALRIVE DRI* 35314369001
CARTE 51002 APPLE ONLINE EURO HOLLYHILL
PAYPAL*PAYPAL*PHIBUELEC 4029357733
PAYPAL*OSCARO COM 35314369001
"