import re
regex = re.compile((r"([A-Z,0-9, ]*\d ){0,1}(?:(\d\d)(\d\d)\/){0,1}([a-z,A-Z,0-9, ,\-,',_,\.,\/ ,\*]*)(?<= )(?:(?:(\-|\+)(\d*,\d\d)){0,1}|(.*))\n"))
test_str = ("CARTE X1796 1209/FREE MOBILE 75 PARIS\n"
"CARTE 51002 ITUNES.COM/BILL LUXEMBURG\n"
"CARTE X1796 0209/SNCF INTERNET 75 PARIS CEDEX 09\n"
"CARTE X1796 1408/THE COLUMBIA STO 124 -156,76\n"
"CARTE X1796 1208/NICKLAUS NORTH G 124 -168,41\n"
"CARTE 51002 PAYPAL*DIGITALRIVE DRI* 35314369001\n"
"CARTE 51002 APPLE ONLINE EURO HOLLYHILL\n"
"PAYPAL*PAYPAL*PHIBUELEC 4029357733\n"
"PAYPAL*OSCARO COM 35314369001\n")
subst = "Nom rationnalisé: $4 $7\\rMoyen de paiement: $1\\rDate opération :$2/$3\\r\\r"
result = regex.sub(subst, test_str)
if result:
print(result)