package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-z]+(?:-[a-z]+)*):\s*([^<]+)`)
var str = `2019-03-07T02:48:17-03:00<br /><br />domain: 100anosdemusica.com.br<br />expires: 20190421<br /><br />country: BR';`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}