$re = '/^(?:(?=.*\d)(?=.*[a-zA-Z]).{8,}|[a-zA-Z0-9]{15,})$/m';
$str = '2232ddds
ddds2222';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);