re = /^(?:(?=.*\d)(?=.*[a-zA-Z]).{8,}|[a-zA-Z0-9]{15,})$/m
str = '2232ddds
ddds2222'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end