$re = '~(?:[a-z]()|[а-яё]())++\1\2~ui';
$str = 'Нужно найти слова подобные следующим: Lюстра, Zaйка и т.д.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);