re = /(?:[a-z]()|[а-яё]())++\1\2/i
str = 'Нужно найти слова подобные следующим: Lюстра, Zaйка и т.д.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end