using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Lorem ipsum dolor sit amet_.*";
string input = @"Lorem ipsum dolor sit amet_0
Lorem ipsum dolor sit amet_1
Lorem ipsum dolor sit amet_2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}