package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Lorem ipsum dolor sit amet_.*`)
var str = `Lorem ipsum dolor sit amet_0
Lorem ipsum dolor sit amet_1
Lorem ipsum dolor sit amet_2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}