$re = '/^.(www\.)?[tunnelbear|camanbet|camanbetweb|betconnections|juegala|anotala|betsa1|betsamerica007|betszoom|eloasiss|superjugadas|vip\-americas|premio365|jazzbet|myapuestas|tuapuestahipica|apuestalotodo|247tujugada|betway|betwin|betcris|1xbet|misportsbook|localcoinswap|coinbase|mercadolar].(com|net|lat)+$/';
$str = 'www.tunnelbear.com
www.camanbet.bet
www.camanbetweb.com
www.betconnections.com
www.juegala.com
www.anotala.com
www.betsa1.com
www.betsamerica007.com
www.betszoom.com
www.eloasiss.com
www.superjugadas.net
www.vip-americas.com
www.premio365.com
www.jazzbet.net
www.myapuestas.com
www.tuapuestahipica.com
www.apuestalotodo.com
www.247tujugada.com
www.betway.lat
www.betcris.com
www.1xbet.com
www.misportsbook.com
www.localcoinswap.com
www.coinbase.com
www.mercadolar.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);