import re
regex = re.compile(r"^.(www\.)?[tunnelbear|camanbet|camanbetweb|betconnections|juegala|anotala|betsa1|betsamerica007|betszoom|eloasiss|superjugadas|vip\-americas|premio365|jazzbet|myapuestas|tuapuestahipica|apuestalotodo|247tujugada|betway|betwin|betcris|1xbet|misportsbook|localcoinswap|coinbase|mercadolar].(com|net|lat)+$")
test_str = ("www.tunnelbear.com\n"
"www.camanbet.bet\n"
"www.camanbetweb.com\n"
"www.betconnections.com\n"
"www.juegala.com\n"
"www.anotala.com\n"
"www.betsa1.com\n"
"www.betsamerica007.com\n"
"www.betszoom.com\n"
"www.eloasiss.com\n"
"www.superjugadas.net\n"
"www.vip-americas.com\n"
"www.premio365.com\n"
"www.jazzbet.net\n"
"www.myapuestas.com\n"
"www.tuapuestahipica.com\n"
"www.apuestalotodo.com\n"
"www.247tujugada.com\n"
"www.betway.lat\n"
"www.betcris.com\n"
"www.1xbet.com\n"
"www.misportsbook.com\n"
"www.localcoinswap.com\n"
"www.coinbase.com\n"
"www.mercadolar.com")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")