#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)transactionId=(?<transactionId>.*?)}.*ResourceId:\s(?<featureName>.*?),.*CPNYID_(?<companyId>\d+)_AID_(?<aPaymentId>\d+)"
Local $sString = "2020-Apr-10 09:32:50.086 PDT [pool-4-thread-1] INFO com.adp.taxmod.lock.service.NTLockServiceImpl {createdDate=Fri Apr 10 09:32:49 PDT 2020, id=4-699211, transactionId=3746ddf0-e602-409b-831c-d0cd995c5595} - NTLockServiceImpl : acquireLock() - ResourceId: CREDIT_RECONCILE, ResourceType: {} CPNYID_25817065_AID_996"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")