package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+\[)(Current Period Result)(\].+\[)(Random field 2)(\].+\/.+\[)(Random field 2)(\].+>\s)(\d+)`)
var str = `abs ((( tonumber( [Current Period Result] ) - tonumber( [Random field 2] )) / tonumber( [Random field 2] ))) > 5
abs ((( tonumber( [Current Period Result] ) - tonumber( [Random field 2] )) / tonumber( [Random field 2] ))) > 10
abs ((( tonumber( [Current Period Result] ) - tonumber( [Random field 2] )) / tonumber( [Random field 2] ))) > 15
abs ((( tonumber( [Current Period Result] ) - tonumber( [Random field 2] )) / tonumber( [Random field 2] ))) > 20
abs ((( tonumber( [Current Period Result] ) - tonumber( [Random field 2] )) / tonumber( [Random field 2] ))) > 25
abs ((( tonumber( [Current Period Result] ) - tonumber( [Random field 2] )) / tonumber( [Random field 2] ))) > 30`
var substitution = "$1NewAmountField$3OldAmountField$5OldAmountField$7$8"
fmt.Println(re.ReplaceAllString(str, substitution))
}