$re = '/(.+\[)(Current Period Result)(\].+\[)(Random field 2)(\].+\/.+\[)(Random field 2)(\].+>\s)(\d+)/m';
$str = 'abs ((( tonumber( [Current Period Result] ) - tonumber( [Random field 2] )) / tonumber( [Random field 2] ))) > 5
abs ((( tonumber( [Current Period Result] ) - tonumber( [Random field 2] )) / tonumber( [Random field 2] ))) > 10
abs ((( tonumber( [Current Period Result] ) - tonumber( [Random field 2] )) / tonumber( [Random field 2] ))) > 15
abs ((( tonumber( [Current Period Result] ) - tonumber( [Random field 2] )) / tonumber( [Random field 2] ))) > 20
abs ((( tonumber( [Current Period Result] ) - tonumber( [Random field 2] )) / tonumber( [Random field 2] ))) > 25
abs ((( tonumber( [Current Period Result] ) - tonumber( [Random field 2] )) / tonumber( [Random field 2] ))) > 30';
$subst = "$1NewAmountField$3OldAmountField$5OldAmountField$7$8";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;