re = /^Failed password for(?: invalid user)? .+ from (?<ipAddress>(?:\d{1,3}\.){3}\d{1,3}) port \d{1,5} ssh\d?$/m
str = 'Failed password for invalid user foo bar from 192.168.1.7 port 49721 ssh2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end