$re = '/sensitive(?i)caseless(?-i)sensitive/m';
$str = 'sensitiveCASELESSsensitive
sensitivecaselessSENSITIVE
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);