re = /sensitive(?i)caseless(?-i)sensitive/m
str = 'sensitiveCASELESSsensitive
sensitivecaselessSENSITIVE
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end