use strict;
my $str = 'Santa Marta is a very special city on the Caribbean Sea in the north of Colombia! It is such a unique place because it was the first Spanish settlement in Colombia and in all of South America!
There are so many magical beaches around here so today I decided to explore one called Taganga! I have no clue what to expect today!!
Let\'s get the adventure started!
THANKS A LOT FOR WATCHING MY VIDEOS!!
►SUPPORT THIS CHANNEL ✅
https://www.paypal.com/paypalme/EKARTER
You can also help the channel grow by like, comment and subscribe. If you have friends who are interested in traveling, sharing videos is also very positive!!
►For more content you can also find me here too,
My Instagram for travel updates: https://bit.ly/35fEpyP
My Facebook for shorter vids: https://bit.ly/3fK7Nyi
My "Funny" Tiktok: https://bit.ly/373IlEh
BUSINESS INQUIRIES: timmykarterbusiness@gmail.com
#timmykarter #colombia #santamarta';
my $regex = qr/^[^\S\n]*\S.*(?:\n[^\S\n]*\S.*)*\n\n[^\S\n]*\S.*(?:\n[^\S\n]*\S.*)*(?=\n\n)
/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}