$re = '/^[^\S\n]*\S.*(?:\n[^\S\n]*\S.*)*\n\n[^\S\n]*\S.*(?:\n[^\S\n]*\S.*)*(?=\n\n)
/m';
$str = 'Santa Marta is a very special city on the Caribbean Sea in the north of Colombia! It is such a unique place because it was the first Spanish settlement in Colombia and in all of South America!
There are so many magical beaches around here so today I decided to explore one called Taganga! I have no clue what to expect today!!
Let\'s get the adventure started!
THANKS A LOT FOR WATCHING MY VIDEOS!!
►SUPPORT THIS CHANNEL ✅
https://www.paypal.com/paypalme/EKARTER
You can also help the channel grow by like, comment and subscribe. If you have friends who are interested in traveling, sharing videos is also very positive!!
►For more content you can also find me here too,
My Instagram for travel updates: https://bit.ly/35fEpyP
My Facebook for shorter vids: https://bit.ly/3fK7Nyi
My "Funny" Tiktok: https://bit.ly/373IlEh
BUSINESS INQUIRIES: timmykarterbusiness@gmail.com
#timmykarter #colombia #santamarta';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);