package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(wss?:\/\/)([0-9]{1,3}(?:\.[0-9]{1,3}){3}|[a-zA-Z]+):([0-9]{1,5})$`)
var str = `ws://0.0.0.0:8080
wss://192.168.0.25:12345
ws://localhost:3333`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}