re = /^(wss?:\/\/)([0-9]{1,3}(?:\.[0-9]{1,3}){3}|[a-zA-Z]+):([0-9]{1,5})$/m
str = 'ws://0.0.0.0:8080
wss://192.168.0.25:12345
ws://localhost:3333'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end