package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/(?<A>\d+)(?:\/(?<B>\d+))?`)
var str = `/1234/5678
/1234
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}