re = /((http|ftp)s?:.*?) /
str = '< Div > 
 	< div id = "header_col2" >  
 		< a href = "index_en.xhtml" title = "Angol version" >  
 			< img src = "eng.jpg" alt = "Angol" height = "25" width = "48 " / > 
 		< / a > 
 	< / div > 
 < / div > 
 < div id = " clear " > 
 < hr / > 
 	<h2 > Some links < / h2 >
 	< P > 
 		< a href = "http://www.math.bme.hu/algebra " > Department of Algebra < / a > < br / > 
 		< a href = "http://www.math.bme.hu/ " > matematics institude < / a > < br / > 
 		< a href = " http://www.bme.hu/ " > BME < / a >  < br / > 
 		< a href = " http://www.bme.hu/~kk0v4cs " > Something else < / a >  <br / > 
 	< / p> 
 < / div >'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end