using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"rmi:\/\/(([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})|([a-zA-Z]{1,3}\.))";
string input = @"{""jmx.serviceUrl"": ""service:jmx:rmi:///jndi/rmi://www.baidu.com:1099/obj""}}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}