$re = '/rmi:\/\/(([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})|([a-zA-Z]{1,3}\.))/m';
$str = '{"jmx.serviceUrl": "service:jmx:rmi:///jndi/rmi://www.baidu.com:1099/obj"}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);