import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(?:1-)?(?:\\$|#|(?:\\((8(?:00|55|66|77|88))\\)|(?1))))\\(?[\\s.-]*([0-9]{3})?[\\s.-]*\\)?[\\s.-]*[0-9]{3}[\\s.-]*[0-9]{4}$";
final String string = "1-800-450-7006 \n"
+ "1 (800) 450-7006 \n"
+ "1(800) 450-7006 \n"
+ "(800) 450-7006\n"
+ "800 450-7006";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}