#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|\n)#EXTINF:(?:-?\d+(\.\d+)?),(.*?)[\r\n]+(.*)"
Local $sString = "" & @CRLF & _
"#EXTM3U" & @CRLF & _
"#EXTINF:O,Telegool TV Bein Sport 1 " & @CRLF & _
"http://stream99.astalavistababy.xyz/priv/b1111/playlist.m3u8" & @CRLF & _
"#EXTINF:0,Telegool TV Bein Sport 2" & @CRLF & _
"http://stream99.astalavistababy.xyz/selcuksportsfutbol/bein2222/playlist.m3u8" & @CRLF & _
"#EXTINF:0,Telegool TV Bein Sport 3" & @CRLF & _
"http://stream99.astalavistababy.xyz/selcuksportsfutbol/bein3333/playlist.m3u8" & @CRLF & _
"#EXTINF:0,Telegool TV Bein Sport 4" & @CRLF & _
"http://stream99.astalavistababy.xyz/selcuksportsfutbol/bein4444/playlist.m3u8" & @CRLF & _
"#EXTINF:0,Telegool TV Beinmax 1" & @CRLF & _
"http://stream99.astalavistababy.xyz/selcuksportsfutbol/beinmax1111/playlist.m3u8" & @CRLF & _
"#EXTINF:0,Telegool TV Beinmax 2" & @CRLF & _
"http://stream99.astalavistababy.xyz/selcuksportsfutbol/beinmax2222/playlist.m3u8" & @CRLF & _
"#EXTINF:0,Telegool TV Tivibu Sport 1" & @CRLF & _
"http://stream99.astalavistababy.xyz/selcuksportsfutbol/tivibu11/playlist.m3u8" & @CRLF & _
"http://stream99.astalavistababy.xyz/selcuksportsfutbol/tivibu22/playlist.m3u8" & @CRLF & _
"#EXTINF:0,Telegool TV Tivibu Sport 3" & @CRLF & _
"http://stream99.astalavistababy.xyz/selcuksportsfutbol/tivibu33/playlist.m3u8" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"#EXTM3U" & @CRLF & _
"#EXTINF:-1,-------------- | SPOR NOX | --------------" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/268.m3u8" & @CRLF & _
"#EXTINF:-1,Bein Sport 1 Hd" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/7.m3u8" & @CRLF & _
"#EXTINF:-1,beIN Sport 1 Hd [ 720p ]" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/16271.m3u8" & @CRLF & _
"#EXTINF:-1,BeIN Sports 1 Sd [ 60 Fps ]" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/16273.m3u8" & @CRLF & _
"#EXTINF:-1,beIN Sport 1 Hd [ dt ]" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/20279.m3u8" & @CRLF & _
"#EXTINF:-1,Bein Sport 1 Hd 1080 Hevc" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/8.m3u8" & @CRLF & _
"#EXTINF:-1,BeIN Sports 1 Hd 1080i 265.hevc" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/16272.m3u8" & @CRLF & _
"#EXTINF:-1,Bein Sport 1 Hevc [ 1920 x 1080 ]" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/16274.m3u8" & @CRLF & _
"#EXTINF:-1,Bein Sport 1 Hd 1080i" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/11.m3u8" & @CRLF & _
"#EXTINF:-1,BeIN Sports 1 Hd 265.hevc [ 60 Fps ]" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/14.m3u8" & @CRLF & _
"#EXTINF:-1,Bein Sport Sd 1 Mobile" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/15.m3u8" & @CRLF & _
"#EXTINF:-1,Bein Sport 1 Hd [ yedek ]" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/16.m3u8" & @CRLF & _
"#EXTINF:-1,Bein Sport 1 [ 360P ]" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/24.m3u8" & @CRLF & _
"#EXTINF:-1,Bein Sport 1 [ 480P ]" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/23.m3u8" & @CRLF & _
"#EXTINF:-1,Bein Sport 1 [ 576P ]" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/22.m3u8" & @CRLF & _
"#EXTINF:-1,Bein Sport 1 4k" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/9.m3u8" & @CRLF & _
"#EXTINF:-1,Bein Sport 1 4k 1080 Hevc" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/10.m3u8" & @CRLF & _
"#EXTINF:-1,Bein Sport 2 Sd" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/17.m3u8" & @CRLF & _
"#EXTINF:-1,Bein Sport 2 Mobile" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/18.m3u8" & @CRLF & _
"#EXTINF:-1,Bein Sport 2 Hd" & @CRLF & _
"http://nox101.com:8080/live/orkun2020/orkun2021/19.m3u8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")