$re = '/(?:^|\n)#EXTINF:(?:-?\d+(\.\d+)?),(.*?)[\r\n]+(.*)/m';
$str = '
#EXTM3U
#EXTINF:O,Telegool TV Bein Sport 1
http://stream99.astalavistababy.xyz/priv/b1111/playlist.m3u8
#EXTINF:0,Telegool TV Bein Sport 2
http://stream99.astalavistababy.xyz/selcuksportsfutbol/bein2222/playlist.m3u8
#EXTINF:0,Telegool TV Bein Sport 3
http://stream99.astalavistababy.xyz/selcuksportsfutbol/bein3333/playlist.m3u8
#EXTINF:0,Telegool TV Bein Sport 4
http://stream99.astalavistababy.xyz/selcuksportsfutbol/bein4444/playlist.m3u8
#EXTINF:0,Telegool TV Beinmax 1
http://stream99.astalavistababy.xyz/selcuksportsfutbol/beinmax1111/playlist.m3u8
#EXTINF:0,Telegool TV Beinmax 2
http://stream99.astalavistababy.xyz/selcuksportsfutbol/beinmax2222/playlist.m3u8
#EXTINF:0,Telegool TV Tivibu Sport 1
http://stream99.astalavistababy.xyz/selcuksportsfutbol/tivibu11/playlist.m3u8
http://stream99.astalavistababy.xyz/selcuksportsfutbol/tivibu22/playlist.m3u8
#EXTINF:0,Telegool TV Tivibu Sport 3
http://stream99.astalavistababy.xyz/selcuksportsfutbol/tivibu33/playlist.m3u8
#EXTM3U
#EXTINF:-1,-------------- | SPOR NOX | --------------
http://nox101.com:8080/live/orkun2020/orkun2021/268.m3u8
#EXTINF:-1,Bein Sport 1 Hd
http://nox101.com:8080/live/orkun2020/orkun2021/7.m3u8
#EXTINF:-1,beIN Sport 1 Hd [ 720p ]
http://nox101.com:8080/live/orkun2020/orkun2021/16271.m3u8
#EXTINF:-1,BeIN Sports 1 Sd [ 60 Fps ]
http://nox101.com:8080/live/orkun2020/orkun2021/16273.m3u8
#EXTINF:-1,beIN Sport 1 Hd [ dt ]
http://nox101.com:8080/live/orkun2020/orkun2021/20279.m3u8
#EXTINF:-1,Bein Sport 1 Hd 1080 Hevc
http://nox101.com:8080/live/orkun2020/orkun2021/8.m3u8
#EXTINF:-1,BeIN Sports 1 Hd 1080i 265.hevc
http://nox101.com:8080/live/orkun2020/orkun2021/16272.m3u8
#EXTINF:-1,Bein Sport 1 Hevc [ 1920 x 1080 ]
http://nox101.com:8080/live/orkun2020/orkun2021/16274.m3u8
#EXTINF:-1,Bein Sport 1 Hd 1080i
http://nox101.com:8080/live/orkun2020/orkun2021/11.m3u8
#EXTINF:-1,BeIN Sports 1 Hd 265.hevc [ 60 Fps ]
http://nox101.com:8080/live/orkun2020/orkun2021/14.m3u8
#EXTINF:-1,Bein Sport Sd 1 Mobile
http://nox101.com:8080/live/orkun2020/orkun2021/15.m3u8
#EXTINF:-1,Bein Sport 1 Hd [ yedek ]
http://nox101.com:8080/live/orkun2020/orkun2021/16.m3u8
#EXTINF:-1,Bein Sport 1 [ 360P ]
http://nox101.com:8080/live/orkun2020/orkun2021/24.m3u8
#EXTINF:-1,Bein Sport 1 [ 480P ]
http://nox101.com:8080/live/orkun2020/orkun2021/23.m3u8
#EXTINF:-1,Bein Sport 1 [ 576P ]
http://nox101.com:8080/live/orkun2020/orkun2021/22.m3u8
#EXTINF:-1,Bein Sport 1 4k
http://nox101.com:8080/live/orkun2020/orkun2021/9.m3u8
#EXTINF:-1,Bein Sport 1 4k 1080 Hevc
http://nox101.com:8080/live/orkun2020/orkun2021/10.m3u8
#EXTINF:-1,Bein Sport 2 Sd
http://nox101.com:8080/live/orkun2020/orkun2021/17.m3u8
#EXTINF:-1,Bein Sport 2 Mobile
http://nox101.com:8080/live/orkun2020/orkun2021/18.m3u8
#EXTINF:-1,Bein Sport 2 Hd
http://nox101.com:8080/live/orkun2020/orkun2021/19.m3u8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);