using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img\s.*?src=(?:'|"")([^'"">]+)(?:'|"")";
string input = @"abc <img src=""static/img/about-me.png"" title="" alt="".";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}