$re = '/<img\s.*?src=(?:\'|")([^\'">]+)(?:\'|")/m';
$str = 'abc <img src="static/img/about-me.png" title="" alt="".';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);