import Foundation
let pattern = ##"(?<=\n)(?<match>.+?(?<phone>\d[\d\s]{7,}).+Reference.+id[\w\W]+#(?<ref>\w+\b))"##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
logo
[https://app.discountdata.ng/assets/images/full-logo.png]https://app.discountdata.ng
Discount Data - Nigeria's topmost enterprise solution to your telecom needs.
NOTIFICATION ALERT
Hi staffdd,
Glo CORPORATE GIFTING 1GB - 30 Days to 08110768733 Reference ID Is :
#202406131022Y5WSUG49ERTYGT666aba5d7dbd3
If you wish to option out from this kind of mail, please contact us or ignore
this message.
If you face any issues, please contact us at help@discountdata.ng
(c) 2024 Discount Data. All rights reserved.
This email was sent to you as a registered member of Discount Data
[https://app.discountdata.ng]. Thank You.
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}