import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'([^'\\}\\{\\\\]*(?:\\\\')?[^'\\}\\{\\\\]*)'(?=(?:[^'\\}\\{\\\\]*(?:'[^'\\}\\{\\\\]*(?:\\\\')?[^'\\}\\{\\\\]*'?)?[^'\\}\\{\\\\]*)\\})";
final String string = "'dont want' don\\'t want {dont want 'want this', 'want this, je m\\'appelle Robert', dont want} don\\'t want 'dont want' {'want this'}\n"
+ "'dont want' and 'don\\'t want'\n"
+ "{'want this' and 'want this, je m\\'appelle Robert'}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}