re = /'([^'}{\\]*(?:\\')?[^'}{\\]*)'(?=(?:[^'}{\\]*(?:'[^'}{\\]*(?:\\')?[^'}{\\]*'?)?[^'}{\\]*)\})/m
str = '\'dont want\' don\\\'t want {dont want \'want this\', \'want this, je m\\\'appelle Robert\', dont want} don\\\'t want \'dont want\' {\'want this\'}
\'dont want\' and \'don\\\'t want\'
{\'want this\' and \'want this, je m\\\'appelle Robert\'}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end