const regex = new RegExp('^(?![-_.])(?!.*[-_.]{2})(?!.*[-_.]$)[-\\w.]{1,36}$', 'gm')
const str = `abcd-efgH
1
a
123
abc
abc-asd-123-asd_asd.asd
-
abc-_asd
abc.
abc.-asd
123123-123123-ads--asd
091-asdsad---`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}