re = /^(?![-_.])(?!.*[-_.]{2})(?!.*[-_.]$)[-\w.]{1,36}$/m
str = 'abcd-efgH
1
a
123
abc
abc-asd-123-asd_asd.asd
-
abc-_asd
abc.
abc.-asd
123123-123123-ads--asd
091-asdsad---'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end