package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\D*0*`)
var str = `U012034`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}