use strict;
my $str = 'U012034';
my $regex = qr/^\D*0*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";